Empty Ox Game project will not run on Clean Windows XP machine

Mar 3, 2010 at 6:16 AM
Edited Mar 3, 2010 at 6:23 AM

I have downloaded the latest Ox Game Engine release. I used Visual Studio 2008 to create a new (XNA 3.1) Ox Game Project.I set my build mode to Release. I right click on my Game Project and lick "Publish..." and I publish the application (using ClickOnce) to my local IIS7 server.

My development machine is Windows 7 64 bit, but I compile the game with the "x86" profile.

I go into my VMWare and Launch a Clean Windows XP Pro installation. I haven't installed anything on it. It is Windows XP Pro version 2002 Service Pack 3.  I go to http://mypc:8080/OxGame/publish.htm where it say
 
Name:  OxGame1
Version:  1.0.0.0
Publisher:  Microsoft
 
The following prerequisites are required:
-Windows Installer 3.1
-.NET Framework 3.5 SP1
-Microsoft XNA Framework Redistributable 3.1
 
And an INSTALL button.

I click on the INSTALL button. It asks me if I accept the agreement for installing .NET Framework 3.5 SP1 and I click Accept, same thing about MS XNA Framework Redist 3.1, I click Accept. Then it says Download the required files..." Then it says "Installing .NET Framework 3.5 SP1..." then it takes a long time for a progress bar to go across as it installs. Then it says "Installing MS XNA Framework Redist 3.1" and then all the windows close. Then the application finally installs, and runs.

Then I get an Error Dialog:

EventType: clr20r3 P1: oxgame1.exe
P9: system.typeinitialization

I've been trying to get ANY application that uses the XNAnimation library (and the Ox Engine does) to run on a clean XP install, but I always get a crash. Something fishy is going on. This is really starting to bother me. Please help me out.

Thanks!

Edit: I posted a thread on GameDev.Net about a similar problem I've been getting when trying to get the XNAnimation library Samples to run on a clean XP install. Same crash happens. The thread for that is right here.

Edit 2: You should be able to access my Publish Website Right Here and click on INSTALL. That is the latest build of the sample. It won't work if my computer is off though.

Coordinator
Mar 4, 2010 at 11:14 AM

That's a question best aimed at Microsoft, maybe at creators.xna.com forums or MS connect.

Cheers!