OxGame1.GameScript.UpdateHook(Microsoft.Xna.Framework.GameTime)': no suitable method found to override

Apr 16, 2010 at 1:56 AM

Hi Bryan, If I run the basic installaion in windows. It runs great.

 

However if I try to run it on the Xbox (after creating copy and wangling about with refs)

I get:

 'OxGame1.GameScript.UpdateHook(Microsoft.Xna.Framework.GameTime)': no suitable method found to override    

C:\Users\Example\Documents\Visual Studio 2008\Projects\OxGame1\OxGame1\GameScript.cs    50    33    Xbox 360 Copy of OxGame1

and it fails to build.

Any ideas?

All projects (Buzby's howto for example) do the same thing when run for the xbox.

I'm downloading the 406 Rev from the SVN to see what i can see, but first glance I'm stumped.

Kind regards,

Simon-john

 

Apr 16, 2010 at 2:22 AM

I compiled and ran a microsoft platformer demo and deployed it to the xbox.

To make sure it wasnt something gooky. Worked fine.

Apr 16, 2010 at 3:14 AM

Nevermind.

The source works fine.

Thanks to this: http://oxgameengine.codeplex.com/Thread/View.aspx?ThreadId=84143 The last post is uberkudos

I ended up with:

engine.Camera.SetViewByLookTarget(engine.Camera.Position, Vector3.Up, balls[balls.Count - 1].Position);

Which worked ok to allow building that project

A few more reference edits and an exclusion of Engine.Test later, and I was 100%

Happily running the Game demo now.

And I must say I almost cried when I saw the shadows running on the xbox, I doff my cap to you.

Nice one Bryan.

Editor
Apr 16, 2010 at 10:19 PM

unfortunately my how to's are kind outdated. if theres demand for it ill update them

Apr 17, 2010 at 11:24 AM

Hi Buzby, I was hoping for some inspiration from your demo, doesn't really matter that it doesn't run.

I do have one question but I'll post it as another thread. Thanks for all your work.