Simply doesn't work. Blank Template has error at Runtime

Aug 4, 2010 at 8:26 PM
Edited Aug 4, 2010 at 8:31 PM
Just to keep things short, I've now tried both the installer, as well as the SVN repository, and both of them throw the same error.


--------------------------------------------------------------------------------------------------

System.InvalidOperationException was unhandled
Message="An unexpected error has occurred."
Source="Microsoft.Xna.Framework"
StackTrace:
at Microsoft.Xna.Framework.Graphics.GraphicsDevice.RawDrawUserIndexedPrimitives(PrimitiveType primitiveType, Int32 numVertices, Int32 primitiveCount, Void* pIndexData, _D3DFORMAT indexFormat, Void* pVertexData, Int32 vertexStride)
at Microsoft.Xna.Framework.Graphics.GraphicsDevice.DrawUserIndexedPrimitives[T](PrimitiveType primitiveType, T[] vertexData, Int32 vertexOffset, Int32 numVertices, Array indexData, Int32 indexOffset, Int32 primitiveCount, _D3DFORMAT indexFormat)
at Microsoft.Xna.Framework.Graphics.GraphicsDevice.DrawUserIndexedPrimitives[T](PrimitiveType primitiveType, T[] vertexData, Int32 vertexOffset, Int32 numVertices, Int32[] indexData, Int32 indexOffset, Int32 primitiveCount)
at Ox.Gui.QuickSpriteNamespace.QuickSpriteBatch.DrawSpriteBatch(Camera camera) in C:\Users\Joshua\Desktop\ox\trunk\OxSolution\Ox\Gui\QuickSprite\QuickSpriteBatch.cs:line 177
at Ox.Gui.QuickSpriteNamespace.QuickSpriteBatch.Draw(GameTime gameTime, Camera camera) in C:\Users\Joshua\Desktop\ox\trunk\OxSolution\Ox\Gui\QuickSprite\QuickSpriteBatch.cs:line 73
at Ox.Gui.QuickSpriteNamespace.QuickSpriteDrawer.DrawBatches(GameTime gameTime, Camera camera) in C:\Users\Joshua\Desktop\ox\trunk\OxSolution\Ox\Gui\QuickSprite\QuickSpriteDrawer.cs:line 106
at Ox.Gui.QuickSpriteNamespace.QuickSpriteDrawer.DrawSprites(GameTime gameTime, Camera camera, IList`1 sprites) in C:\Users\Joshua\Desktop\ox\trunk\OxSolution\Ox\Gui\QuickSprite\QuickSpriteDrawer.cs:line 66
at Ox.Gui.GuiSystem.DrawSprites(GameTime gameTime) in C:\Users\Joshua\Desktop\ox\trunk\OxSolution\Ox\Gui\GuiSystem.cs:line 366
at Ox.Gui.GuiSystem.Draw(GameTime gameTime) in C:\Users\Joshua\Desktop\ox\trunk\OxSolution\Ox\Gui\GuiSystem.cs:line 174
at Ox.DefaultEngineNamespace.DefaultEngine.DrawHook(GameTime gameTime) in C:\Users\Joshua\Desktop\ox\trunk\OxSolution\Ox\DefaultEngine\DefaultEngine.cs:line 226
at Ox.Engine.OxEngine.Draw(GameTime gameTime) in C:\Users\Joshua\Desktop\ox\trunk\OxSolution\Ox\Engine\OxEngine.cs:line 298
at GuiDemoNamespace.GuiDemo.Draw(GameTime gameTime) in C:\Users\Joshua\Desktop\ox\trunk\GuiDemo\GuiDemo.cs:line 72
at Microsoft.Xna.Framework.Game.DrawFrame()
at Microsoft.Xna.Framework.Game.Tick()
at Microsoft.Xna.Framework.Game.HostIdle(Object sender, EventArgs e)
at Microsoft.Xna.Framework.GameHost.OnIdle()
at Microsoft.Xna.Framework.WindowsGameHost.ApplicationIdle(Object sender, EventArgs e)
at System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32 grfidlef)
at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(Int32 dwComponentID, Int32 reason, Int32 pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(Form mainForm)
at Microsoft.Xna.Framework.WindowsGameHost.Run()
at Microsoft.Xna.Framework.Game.Run()
at GuiDemoNamespace.Program.Main(String[] args) in C:\Users\Joshua\Desktop\ox\trunk\GuiDemo\Program.cs:line 12
InnerException:
----------------------------------------------------------------------------------------------------------

Just for completeness, here's a screenshot.

http://bit.ly/cJIVKL

I don't really know what's going on, as the error message doesn't really give me any worthwhile information.
This particular machine is a few years old, and a laptop on top of that. I could potentially see a problem in the graphics device. It has the Intel GMA950, which only supports Shader 2.0. Could that be the problem?
Aug 4, 2010 at 9:52 PM

Uhmmm, don't see why your having problems.  I just installed it using the download, created a project using VS2008 and everything ran perfect.

Aug 4, 2010 at 10:03 PM

BUT, I do have one problem so far.  I can't load the generated .xml files in there corresponding Editors except for the General Editor for the "GameDocument.xml".  Keeps getting an load error on the others.

Editor
Aug 4, 2010 at 11:09 PM

ox is shader model 3.0

dont know much about installing it with studio, im cheap and only use express :D

-bubzy

Coordinator
Aug 5, 2010 at 6:01 AM
Yep, inadequate video card.
Aug 5, 2010 at 8:35 AM
While I am a firm believer that current technology should not hold back innovation...
I can't help but be a bit disappointed about the inadequacy of my integrated graphics.

Normally I wouldn't have this problem, but my main development PC is on the fritz. Ironically, it's a bad video card.
Just as luck would have it, I don't have the money to allocate to replacing it.

Oh well, such is life. Guess I'll get used vanilla XNA again, or even worse, WinForms (Gasp!)

I'd like to thank the community for such an expedient response. I'm sure Ox is everything I hoped for and more, I'm just sorry I can't sing praises from experience.
Editor
Aug 6, 2010 at 7:34 AM

come back when u get a video card, its really worth it :)